Cloud connectivity

Incident Report for Meraki

Resolved

This incident is now resolved. All systems should be operating normally at this time. If you continue to experience issues, please feel free to contact Customer Support.
Posted Dec 15, 2025 - 21:15 UTC

Monitoring

A mitigation is in place that has restored normal functionality. Our engineering teams continue to monitor this solution to confirm correct behavior.
Posted Dec 15, 2025 - 19:24 UTC

Identified

We are aware that some customers are having issues with Meraki cloud authentication, device to cloud connectivity and similar cloud services which rely on live network telemetry. Our engineers are actively working on remediating these issues.
Posted Dec 15, 2025 - 18:09 UTC