This incident is now resolved. All systems are performing as expected. If you continue to experience issues, please contact Meraki Support.
Posted Apr 17, 2025 - 16:50 UTC
Monitoring
Our teams have deployed a fix and regular service is now restored. We are continuing to monitor the situation.
Posted Apr 17, 2025 - 16:24 UTC
Identified
We have identified the problem and are working to remediate it now. We will provide further updates as the incident progresses.
Posted Apr 17, 2025 - 13:08 UTC
Update
We are continuing to investigate this issue. We will provide the next update as soon as more information becomes available.
Posted Apr 17, 2025 - 12:50 UTC
Investigating
We are aware that some customers in EMEA are experiencing Cloud Monitored Catalyst Switches appearing offline in the Dashboard and we are actively investigating this issue. We will provide the next update as soon as more information becomes available.