Client Details Page
Incident Report for Meraki
Resolved
This incident is now resolved. All systems are performing as expected. If you continue to experience issues, please contact Meraki Support.
Posted Oct 28, 2024 - 19:33 UTC
Monitoring
Our teams are in the process of rolling out a mitigation to the Meraki Cloud. Some customers may have already regained access to the Clients Details page. These efforts are active, and ongoing.
Posted Oct 28, 2024 - 18:39 UTC
Identified
We understand that many customers cannot access the Client Details page in Meraki Dashboard. Our teams are aware of the issue, and are actively working to mitigate it.
Posted Oct 28, 2024 - 17:46 UTC