This incident is now resolved. All systems are performing as expected. If you continue to experience issues, please contact Cisco Meraki Support.
Posted Apr 22, 2025 - 03:15 UTC
Monitoring
Our teams have deployed a fix and all services should be restored now. We are continuing to monitor the situation.
Posted Apr 22, 2025 - 02:11 UTC
Identified
We have identified the problem and are working to remediate it now. We will provide further updates as the incident progresses.
Posted Apr 22, 2025 - 01:27 UTC
Investigating
We are aware that a subset of newly added devices are having issues connecting to the Cisco Meraki Dashboard. Devices already online and connected should not be experiencing any impact. Our teams are actively investigating the issue.