Meraki Support Phone Outage

Incident Report for Meraki

Resolved

The issues connecting to the Support team via phone are now resolved. Thank you for your patience.
Posted Oct 21, 2025 - 01:07 UTC

Update

We are continuing to monitor the situation related to issues connecting to the Support team via phone, with indications that the service is recovering. If you continue to experience issues attempting to contact us via our Support Hotline please follow these steps. For new cases, please open a case and choose the "Call In" option including "Outage Oct/20" in the subject. For existing cases, please provide a case comment with the phrase "Outage. We appreciate your patience and understanding as we work to restore full service.
Posted Oct 20, 2025 - 21:38 UTC

Monitoring

We are actively monitoring the situation related to issues connecting to the Support team via phone. If you continue to experience issues attempting to contact us via our Support Hotline please follow these steps. For new cases, please open a case and choose the "Call In" option including "Outage Oct/20" in the subject. For existing cases, please provide a case comment with the phrase "Outage. We appreciate your patience and understanding as we work to restore full service.
Posted Oct 20, 2025 - 16:45 UTC

Investigating

We are currently experiencing issues connecting to the Support team via phones. Our team is actively working on this. For new cases, please open a case and choose the "Call In" option including "Outage Oct/20" in the subject. For existing cases, please provide a case comment with the phrase "Outage".
Posted Oct 20, 2025 - 15:08 UTC