Dashboard access issues.

Incident Report for Meraki

Resolved

This incident is now resolved. All systems are performing as expected. If you continue to experience issues, please contact Meraki Support.
Posted Nov 15, 2024 - 14:50 UTC

Update

We are continuing to monitor our systems for correct behaviour.
Posted Nov 15, 2024 - 12:45 UTC

Monitoring

A mitigation has been deployed to our systems and we are continuing to monitor the results.
Posted Nov 15, 2024 - 10:28 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 15, 2024 - 08:19 UTC

Identified

We have identified the cause of the issue, and our teams are actively working on putting mitigation in place.
Posted Nov 15, 2024 - 08:17 UTC

Update

We are continuing to investigate this issue.
Posted Nov 15, 2024 - 07:14 UTC

Investigating

We are aware that some customers are having difficulty either logging into or accessing pages on Cisco Meraki Dashboard. Our teams are actively working on remediating this issue.
Posted Nov 15, 2024 - 07:13 UTC