This incident is now resolved. All systems are operating normally. If you continue to see issues, please feel free to contact Meraki Customer Support.
Posted Aug 23, 2024 - 23:16 UTC
Monitoring
Our engineering teams have deployed a fix to mitigate impact to customers. To ensure you can take advantage of this fix, you will need to perform a cache-less refresh of your web browser. On a Mac, shift-clicking the Reload button should work, or on Windows, Ctrl-clicking the Reload button. In the meantime, our engineering teams continue to monitor systems to confirm correct behavior.
Posted Aug 23, 2024 - 21:53 UTC
Identified
We are aware that some customers are having difficulty either logging into or accessing pages on Meraki Dashboard. Further, some of the functionality in Dashboard page footers and utilities may not behave as expected. Our engineering teams have identified a likely cause, and are actively working to mitigate the issue.