Dashboard Outage
Incident Report for Meraki
Resolved
This incident is now Resolved. All systems are operating normally. If you are still having issues, please don't hesitate to reach out to Meraki Support.
Posted May 06, 2024 - 20:50 UTC
Identified
Our teams have isolated what we believe to be the root of the performance issues that some customers may be experiencing, and have implemented mitigative measures. Customers should begin to see a return to normal performance soon.
Posted May 06, 2024 - 19:57 UTC
Investigating
We are investigating an issue with the Meraki Dashboard that is impacting some users. Next update as soon as more information becomes available.
Posted May 06, 2024 - 19:25 UTC