Dashboard access issues

Incident Report for Meraki

Resolved

This incident is now resolved. All services are performing as expected. If you continue to have issues, please contact Meraki Customer Support.
Posted Oct 10, 2024 - 03:28 UTC

Monitoring

Our teams are deploying a mitigation to our systems, and are continuing to monitor them for normal function.
Posted Oct 10, 2024 - 00:43 UTC

Identified

We have identified the cause of the issue, and our teams are actively working on putting a mitigation in place.
Posted Oct 09, 2024 - 23:43 UTC

Investigating

We are aware that a significant number of customers may be having challenges connecting to the Meraki Dashboard, as well as associated tools such as Vision Portal. We have a team actively investigating.
Posted Oct 09, 2024 - 23:26 UTC