Resolved
This incident has been resolved.
Posted May 21, 2026 - 14:10 UTC
Monitoring
Our teams have identified a root cause, and applied a mitigation. We are seeing improved behavior, and are monitoring for correct expected behavior across all systems.
Posted May 21, 2026 - 13:43 UTC
Identified
We have identified an issue currently whereby some customers are unable to make changes in the Cisco Meraki dashboard. Our teams are currently actively working to resolve this issue. As a workaround to avoid this issue please review addresses populated on devices in your dashboard based on the invalid characters shown in the error message received when attempting to save.
Posted May 21, 2026 - 11:42 UTC
This incident affected: North and South America (Dashboard, API, Network Device Connectivity, End User Device Connectivity, Access Point, Switch, WAN appliance, Camera), Europe (Dashboard, API, Network Device Connectivity, End User Device Connectivity, Access Point, Switch, WAN appliance, Camera), Asia-Pacific (Dashboard, API, Network Device Connectivity, End User Device Connectivity, Access Point, Switch, WAN appliance, Camera), Canada (Dashboard, API, Network Device Connectivity, End User Device Connectivity, Access Point, Switch, WAN appliance, Camera), China (Dashboard, API, Network Device Connectivity, End User Device Connectivity, Access Point, Switch, WAN appliance), and India (Dashboard, API, Network Device Connectivity, End User Device Connectivity, Access Point, Switch, WAN appliance).