Dashboard Outage

Incident Report for Meraki

Resolved

This incident is now resolved. We are sorry for any interruption to your service.
Posted 1 year ago. Feb 15, 2024 - 08:37 UTC

Investigating

We are investigating an issue with the Meraki Dashboard that is intermittently preventing some users from viewing switch-related pages. Next update as soon as more information becomes available
Posted 1 year ago. Feb 14, 2024 - 22:42 UTC