Firmware page unavailable

Incident Report for Meraki

Resolved

This incident has been resolved. Normal service behavior has been restored.
Posted Apr 11, 2023 - 07:06 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2023 - 06:12 UTC

Identified

We have identified that Navigating to Organization > Firmware upgrades is failing. A fix is being prepared and will soon be applied.
Posted Apr 11, 2023 - 04:45 UTC

Investigating

We are investigating an issue with the Meraki Dashboard that is impacting users' ability to view the firmware page. Next update as soon as more information becomes available.
Posted Apr 11, 2023 - 03:03 UTC