Our teams have identified the root cause and applied a mitigation. We are seeing improved behavior and are monitoring all systems to ensure they are operating as expected.
Posted Jun 12, 2026 - 04:03 UTC
Investigating
We are aware of an issue affecting Dashboard that may be causing some pages to display incorrectly for some customers.
Our team is actively investigating the issue and working toward a resolution. We will provide another update as soon as we have more information.
Posted Jun 12, 2026 - 03:20 UTC
This incident affected: North and South America (Dashboard), Europe (Dashboard), Asia-Pacific (Dashboard), Canada (Dashboard), and India (Dashboard).