Summary reports loading slower than normal

Incident Report for Meraki

Resolved

Our engineering teams have verified that all systems are now operating normally. This incident is now Resolved.
Posted Mar 24, 2023 - 21:02 UTC

Monitoring

Our engineering teams have completed deployment of a fix for the issue that was causing the longer than normal load times for Summary pages. We will continue to monitor those systems to confirm a return to normal behavior.
Posted Mar 24, 2023 - 20:49 UTC

Update

In addition to the customer impacts described earlier, it is now clear that latency to the getOrganizationDevices API endpoint is also elevated. This may result in delays in response from that API endpoint, as well a possible overall degradation to Dashboard performance.
Posted Mar 24, 2023 - 20:08 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 24, 2023 - 18:27 UTC

Identified

Customers who are trying to load Summary reports may experience longer than normal load times. Our engineering teams are aware of the problem, and are actively working on a remediation for this issue.
Posted Mar 24, 2023 - 18:26 UTC