Dashboard Access Issue
Incident Report for Meraki
Resolved
We have remediated the issue that was causing customer impact. All systems are now operating normally. If you continue to encounter issues, please reach out to Meraki Customer Support.
Posted Nov 08, 2023 - 15:14 UTC
Identified
We have identified sporadic performance issues affecting the Cisco Meraki Dashboard, leading to extended page load times or, in some cases, pages failing to load. Our response teams are actively working to address and resolve the issues. We encourage you to check back from time to time for further updates, which will be provided promptly as new information becomes available.
Posted Nov 08, 2023 - 12:55 UTC
Investigating
We are aware that some customers have experienced Dashboard access issues, and we are actively investigating.
Posted Nov 08, 2023 - 11:14 UTC