After monitoring, this issue is believed to be fully resolved. If you experience further issues, please don't hesitate to contact Meraki Support.
Posted May 23, 2024 - 04:45 UTC
Monitoring
A fix for the issue loading splash pages in the China dashboard has been rolled out and verified. If you experience further issues, please don't hesitate to contact Meraki Support.
Posted May 23, 2024 - 03:45 UTC
Identified
We are aware that Meraki Dashboard customers using the China Dashboard may be encountering issues when trying to load Splash Pages. Our engineers have identified what they believe to be the source of the issue, and are actively working on applying a fix.