The issue involving customers being unable to reach our support team via phone has been resolved. If you continue to experience issues attempting to contact us via our Support Hotline please follow these steps. For new cases please open a case and choose the "Call In" option, for existing cases please provide a case comment with the phrase "10-15-Outage" and we will reach out to you as soon as possible.
Posted Oct 15, 2025 - 22:31 UTC
Monitoring
The issue involving customers being unable to reach our support team via phone has been resolved. We are actively monitoring the situation but if you continue to experience issues attempting to contact us via our Support Hotline please follow these steps. For new cases please open a case and choose the "Call In" option, for existing cases please provide a case comment with the phrase "10-15-Outage" and we will reach out to you as soon as possible. We appreciate your patience and understanding as we work to restore full service.
Posted Oct 15, 2025 - 21:49 UTC
Investigating
We are currently experiencing issues connecting to the Support team via phone. Our team is actively working to resolve this as quickly as possible. For new cases please open a case and choose the "Call In" option, for existing cases please provide a case comment with the phrase "10-15-Outage" and we will reach out to you as soon as possible. We appreciate your patience and understanding as we work to restore full service.