Our teams have confirmed that the prior issues regarding Live Tools and/or viewing live data for network devices have been resolved. All systems are now operating normally. If you continue to see issues, please contact Meraki Customer Support.
Posted May 01, 2026 - 23:14 UTC
Monitoring
Our teams have identified a root cause, and applied a mitigation. We are seeing improved behavior, and are monitoring for correct expected behavior across all systems.
Posted May 01, 2026 - 18:34 UTC
Investigating
We are aware of an issue with Dashboard where some customers may be having issues using the Live Tools and/or viewing live data regarding their network devices. We are actively triaging the issue, and will post an update when we know more.
Posted May 01, 2026 - 18:15 UTC
This incident affected: North and South America (Dashboard), Europe (Dashboard), Asia-Pacific (Dashboard), Canada (Dashboard), China (Dashboard), and India (Dashboard).