Meraki Dashboard navigation issues
Incident Report for Meraki
Resolved
A fix for the rendering and navigation issues with Meraki Dashboard has been rolled out and verified. Meraki Dashboard is now operating as expected. If you experience further issues, please don't hesitate to contact Meraki Support.
Posted May 21, 2024 - 23:38 UTC
Update
We are aware that Meraki Dashboard customers may be encountering issues with how the Meraki Dashboard is rendered, as well as navigation within the Dashboard. Engineers have identified the issue and are actively working on applying a fix.
Posted May 21, 2024 - 21:18 UTC
Identified
We are aware of Meraki Dashboard customers may be encountering issues with the left-hand navigation in the Meraki Dashboard. Engineers have identified what they believe to be the source of the issue, and are actively working on applying a fix.
Posted May 21, 2024 - 21:11 UTC