Issues with the Client Details Page

Incident Report for Meraki

Resolved

This incident is now resolved. All systems are performing as expected. If you continue to experience issues, please contact Meraki Support.
Posted Apr 01, 2025 - 20:24 UTC

Monitoring

Our teams are in the process of rolling out a mitigation to the Meraki Cloud. These efforts are active and ongoing.
Posted Apr 01, 2025 - 16:34 UTC

Identified

We have identified the problem and are working to remediate it now. We will provide further updates as the incident progresses.
Please continue using the old version of the page as a workaround in the meantime.
Posted Apr 01, 2025 - 14:18 UTC

Investigating

We are investigating further performance issues with the Client Details Page since a fix was deployed that is impacting some users. Switching to the old version of the page should avoid these issues and can be used as a workaround in the meantime.
Posted Apr 01, 2025 - 13:25 UTC

Monitoring

Our teams are in the process of rolling out a mitigation to the Meraki Cloud. Some customers may have already regained access to the Clients Details page. These efforts are active, and ongoing.
Posted Apr 01, 2025 - 12:19 UTC

Update

We have identified a fix for this issue. It is currently going through vigorous testing before being deployed to our systems.
Please continue using the old version of the page as a workaround in the meantime.
Posted Apr 01, 2025 - 11:54 UTC

Update

We have identified the cause of the issue, and our teams are actively working on putting mitigation in place.
Please continue using the old version of the page as a workaround in the meantime.
Posted Apr 01, 2025 - 07:58 UTC

Identified

We have identified the problem and are working to remediate it now. We will provide further updates as the incident progresses.
Please continue using the old version of the page as a workaround in the meantime.
Posted Apr 01, 2025 - 03:20 UTC

Investigating

We are investigating an issue with the Client Details Page that is impacting some users. Switching to the old version of the page should allow the page to load and can be used as a workaround in the meantime.
Posted Apr 01, 2025 - 03:12 UTC